Problem
You receive one of the following errors on your BlackBerry device while using Application Loader to install purchased software:
Device Error 505
Device Error 507
Both errors indicate that no applications are loaded on the BlackBerry device.
Cause
There are three possible causes for this issue:
Cause 1
During the Application Loader process, the existing applications on the BlackBerry device were erased, but Application Loader failed to load the new applications.
Resolution
Complete the following steps:
- Verify that device software is installed on your computer.
- If your BlackBerry device is connected to a laptop in a docking station, disconnect the laptop from the docking station and connect the device directly to the laptop.
- If a third-party program (e.g. virus scanner) is using the same COM port as BlackBerry Desktop Manager, close the third-party application to free the COM port.
- If you are using a USB adapter to connect your BlackBerry device to a serial port on your computer, temporarily connect your device to a computer with a USB port.
- In Desktop Manager, double-click Application Loader.
- Use Application Loader to install the device software.
Cause 2
You
erased all the data and applications on your BlackBerry device by
typing an incorrect password ten times in Application Loader.
Resolution
Complete the following steps:
- In Desktop Manager, double-click Application Loader.
- Use Application Loader to install the device software.
Cause 3
Power management has disabled your USB ports.
Note: WIN XP ONLY
Resolution
- Click Start > Control Panel
- Click on System > Hardware tab > Device Manager button
- Double clcik on Universal Serial Bus controllers
- Right clcik on the 1st USB root hub and select Properties
- Click on the Power Management tab
- Remove the checkmark beside "Allow the computer to turn off this device to save power"
- Repeat for all other USB root hubs & then reboot the computer.